system-release >= 10.90 is needed by package rpmfusion-free-release-10.90-1.noarch (rpmfusion-free-rawhide)

Last Updated on 1월 16, 2009 by 태랑(정현호)

RPMFUSION을추가 해서 사용하다 보면 종종 업데이트하다가
의존성 문제로 안되는경우가 있다 이번버번은 좀 해결하기 힘들어서 기존
db를 지우고 새로 깨끗하게 설치하는법으로  해결하게되었다
이문제로 다른분들도 찾을것같아서 에러메세지전부를 제목으로 넣었다

--------------------------------------------------------------
system-release >= 10.90 is needed by package rpmfusion-free-release-10.90-1.noarch (rpmfusion-free-rawhide)
-------------------------------------------------------------------------

밑에 부분을 스크립트로 만든후 x(실행권환을 줘서 실행하면 되는데 그전에
rpm -ivh http://download1.rpmfusion.org/nonfr…0-1.noarch.rpm
http://download1.rpmfusion.org/free/…0-1.noarch.rpm
이부분을 여기 블로그에있는 파일을 다운받은후 경로를 수정해주길 바란다
(보라색부분을 다운로드 받고 실제파일경로로 수정)
4970beeaea1d397.rpm4970beeb0c6e19M.rpm
** 페도라 10버전에 관련된 파일입니다**

----------------밑의 내용을 스크립트로 만드셔서 실행하세요 --------------
#!/bin/bash
 echo "remove current rpmfusion repositories …"
 rpm -e rpmfusion-free-release rpmfusion-nonfree-release --nodeps
 rm -f /etc/yum.repos.d/rpmfusion*.repo
 
 echo "resinstall rpmfusion repository …"
 rpm -ivh http://download1.rpmfusion.org/nonfr…0-1.noarch.rpm http://download1.rpmfusion.org/free/…0-1.noarch.rpm # --httpproxy proxy_IP_address --httpport 8080
 
 echo "Rebuild yum local database …"
 yum clean all
 yum makecache

원문
http://forums.fedoraforum.org/showthread.php?p=1138789

답글 남기기