AWS 에 라이믹스(XE) 설치 - Rhymix 설치 - 2.0.0 출시 - XpressEngine - 우분투

Rhymix Rhymix는 XpressEngine 1.8 버전을 포크(fork)하여 개발되어지고 있는 PHP CMS(저작물 관리 시스템) 입니다. XETOWN이라는 XE 사용자 커뮤니티에서 시작된 소프트웨어로, 흔히 라이믹스라고 불리고 있습니다. XE 는 현재 1.11.6 으로 큰 변화나 업데이트 없이 일부 보안적인 수정사항으로 종종 업데이트가 되고 있고 XE3…

리눅스에 APM(Apache + PHP + MySQL) 설치 및 연동

* 2021년 4월 3일 업데이트 - 변경사항은 계속 업데이트 되어 최신화 되고 있습니다 [들어가기전에] 해당포스팅은 오라클 클라우드 프리티어, APM 스택구성, 도메인 설정, 워드프레스 구축 까지 이어지는 연재글의 중간글 입니다 하단의 링크를 통해 다음 단계의 포스팅을 보실 수 있습니다. 이전글 오라클…

PHP 5.6 + Suhosin + Zend Guard + memcached + Opcache

PHP 5.6을 Source Compile 로 설치 하면서 + Zend Guard + Suhosin + memcached + Opcache 등을 같이 구성하는 글 입니다. ## 선행 패키지 설치 [root]# yum -y install curl curl-devel zlib.x86_64 zlib-devel.x86_64 \freetype.x86_64 freetype-devel.x86_64 freetype-utils.x86_64 \gd.x86_64 gd-devel.x86_64 libjpeg.x86_64 libjpeg-devel.x86_64 \libpng.x86_64…

PHP 5.3.28 zend_language_parser.h:317: error

PHP 5.3.28 을 source 버전으로 컴파일(make) 시 zend_language_parser.h 파일에서 에러 발생시 파일을 수정 후 다시 컴파일을 한다(317 줄) TRANT  -I/usr/include -g -O2 -fvisibility=hidden -pthread -DZTS   -c /root/php-5.3.28/ext/standard/basic_functions.c -o ext/standard/basic_functions.lo In file included from /root/php-5.3.28/ext/standard/basic_functions.c:49: /root/php-5.3.28/Zend/zend_language_parser.h:317: error: conflicting types for 'zendparse' /root/php-5.3.28/Zend/zend_globals_macros.h:35:…