YUM - Repodata is over 2 weeks old / Warning: Group development does not have any packages to install.

Last Updated on 11월 24, 2020 by 태랑(정현호)


1) YUM으로 패키지 설치 시 아래와 같은 메세지 발생시

Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast

Repository에 2주 이상 접속하지 않았을 경우 서버에 저장된 패키지의 목록의 Cache가 오래되어 나오는 오류 메세지 입니다.
yum clean으로 해결할 수 있습니다.


[root]# yum clean all

clean all 실행후, 설치하려고 한 패키지를 다시 설치 합니다.



2) Centos7 에서 개발 패키지 모임인 "Development Tools" 설치시 아래와 같은 메세지가 출력되고 설치가 되지 않는 현상
Warning: Group development does not have any packages to install.


[root]# yum -y groupinstall "Development Tools"
Loaded plugins: fastestmirror
There is no installed groups file.
Maybe run: yum groups mark convert (see man yum)
Loading mirror speeds from cached hostfile

Warning: Group development does not have any packages to install.
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update



--setopt 를 추가로 입력하여 실행 합니다.
[root]# yum groupinstall "Development Tools" \
--setopt=group_package_types=mandatory,default,optional


Ref Link
https://access.redhat.com/discussions/1262603


답글 남기기